您好,欢迎来到[编程问答]网站首页   源码下载   电子书籍   软件下载   专题
当前位置:首页 >> 编程问答 >> Web开发 >> Cannot find module 'brace-expansion' 运行npm run dev报错

Cannot find module 'brace-expansion' 运行npm run dev报错

来源:网络整理     时间:2018/1/29 1:01:09     关键词:

关于网友提出的“ Cannot find module 'brace-expansion' 运行npm run dev报错”问题疑问,本网通过在网上对“ Cannot find module 'brace-expansion' 运行npm run dev报错”有关的相关答案进行了整理,供用户进行参考,详细问题解答如下:

问题: Cannot find module 'brace-expansion' 运行npm run dev报错
描述:

背景:
使用vue-cli创建的vue项目,
使用cnpm镜像

问题:
使用cnpm安装了sockjs包,后来想把他给卸载了,运行了cnpm uninstall sockjs,报错没能成功,如下


后又尝试了npm的卸载,仍然报错,放弃卸载,安装了 stompjs
成功后,写了stompjs的代码,准备跑一下,运行了npm run dev,报错:

重点是,这个问题是连环的,提示没有'brace-expansion',安装完成后,又会有别的模块找不到。

现在的笨方法就是项目重新安装。


解决方案1:

只能删除node_modules再重装了
cnpm安装包会出现很多奇怪的问题,有些包都是要求不要用cnpm安装了
可以用npm install 包名 --registry=https://registry.npm.taobao.org的方式,这样仍是用npm安装不过是换了个源


以上介绍了“ Cannot find module 'brace-expansion' 运行npm run dev报错”的问题解答,希望对有需要的网友有所帮助。
本文网址链接:http://www.codes51.com/itwd/4537123.html

相关图片

相关文章