您好,欢迎来到[编程问答]网站首页   源码下载   电子书籍   软件下载   专题
当前位置:首页 >> 编程问答 >> .NET >> 用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序

用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序

来源:网络整理     时间:2016/5/19 2:00:31     关键词:

关于网友提出的“用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序”问题疑问,本网通过在网上对“用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序”有关的相关答案进行了整理,供用户进行参考,详细问题解答如下:

问题:用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序
描述:

oracle框架

RT,如何处理,
选择从数据库生成,数据库连接都配好了,就是准备选择表的时候出现这个提示。
用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序
还有我试了下,引用framework5的版本的话是能生成的。
我下载应该已经是最新版本了,有人能指点下吗?或者比较全的教程,万分感谢!


解决方案1:

我也遇到这个问题:vs2015升级后连接Oracle 找不到进行数据连接所需的与最新版实体框架,
在NuGet 程序包括管理器中安装两个dll 即可
用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序
用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序

解决方案2:

楼主,你解决了能分享一下吗?

解决方案3:

楼主,能分享一下吗,急需。

解决方案4:

楼主能给指点一二吗,我现在也出现这个界面,如果不用database,用codefirst,怎么修改3层内容,数据库表现在创建好了,是不是可以直接用呢,如果能有例子就最好了

解决方案5:

又不是亲儿子,还想用新的~~呵呵~~
如果想用DB First的话,可以考虑一些第三方的~~
http://www.telerik.com/download/data-access

解决方案6:

恭喜lz自己解决。我是来接分的。


以上介绍了“用EF for oracle 时出现 您的项目引用了最新版实体框架;但是,找不到进行数据连接所需的与最新版实体框架兼容的实体框架数据库提供程序”的问题解答,希望对有需要的网友有所帮助。
本文网址链接:http://www.codes51.com/itwd/1172504.html

相关图片

相关文章