ASP源码.NET源码PHP源码JSP源码JAVA源码DELPHI源码PB源码VC源码VB源码Android源码
当前位置:首页 >> 网络编程 >> Python教程 >> Python pip – error: invalid command ‘bdist_wheel’

Python pip – error: invalid command ‘bdist_wheel’

来源:网络整理     时间:2015-08-22     关键词:

本篇文章主要介绍了"Python pip – error: invalid command ‘bdist_wheel’",主要涉及到方面的内容,对于Python教程感兴趣的同学可以参考一下: 原文@http://software-engineer.gatsbylee.com/python-pip-error-invalid-command-bdist...

原文@http://software-engineer.gatsbylee.com/python-pip-error-invalid-command-bdist_wheel/

Python pip – error: invalid command ‘bdist_wheel’

环境

  • python-setuptools 0.6.10 from CentOS 6 Base
  • pip 7.1.0 from https://bootstrap.pypa.io/get-pip.py
  • python 2.6

问题?

When I install python modules, such ans Flask, SQLAlchemy, etc., I got this error “error: invalid command ‘bdist_wheel'”.

原因?

This is compatibility issue between pip and setuptools.

The python-setuptool 0.6.10 from CentOS 6 uses python module, setuptools.

from setuptools import setup

However, the pip 7.1.0 expects that the installed python setuptool module use distutils.core.

from distutils.core import setup

 解决方案?

There could be two approaches.

1. using the pip packages from CentOS 6 which is 1.3.1.

$ python -m pip uninstall pip setuptools
$ yum install python-pip python-setuptools

2. upgrading python setuptool module

$pip install setuptools --upgrade

以上就介绍了Python pip – error: invalid command ‘bdist_wheel’,包括了方面的内容,希望对Python教程有兴趣的朋友有所帮助。

本文网址链接:http://www.codes51.com/article/detail_164092.html

相关图片

相关文章